Possible Bug/Note Mistake With Shortcuts.

HictorHictor Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 327 Enthusiast
edited October 2018 in HitFilm

So, while trying to familiarize my fingers with Hitfilm shortcuts, I found that by pressing CTRL + Shift + A creates plane (as its supposed to!) but does not immediately throw in my composite. Instead, I have to fish it out of my media panel. Is this the intended workflow? 

Also, I would like to indicate that there's some confusion in the way documentation is done. 

When it comes to expanding my timeline, Holding Shift + is the said to be the right combination.

While this is true, it doesn't make it immediately clear that the intended + was actually the Numpad's +

As you can imagine, spent a few minutes opening & restarting Hitfilm trying in vain to make use to Shift +, before I realized it was Shift NUMPAD +  :p

Even when you go to Hitfilm's shortcut settings, it doesn't make that distinction.

Confusing, but hey. No harm done.

Comments

  • CleverTaglineCleverTagline Moderator Las Vegas, NVModerator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,038 Ambassador

    Not sure about the Windows version, but in the Mac version there's a different key combo to make a new plane and add it to the current comp. Shift-Command-A just makes a plane, while Option-Command-A makes it and adds it to the comp. Check the New Layer menu in a comp and you'll see the key combos listed next to each item.

    Re: the timeline scale, I think the hiccup you're encountering is because the non-numpad + requires a Shift already, so technically you're typing Shift = to get +. Actually doing Shift + on that key would require somehow doubling the Shift modifier, which isn't possible. If you want, you can change the hotkey to something like Ctrl +. That way a normal Ctrl + would work on the numpad, and Shift-Ctrl + would work on the other key.

  • HictorHictor Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 327 Enthusiast
    edited October 2018

    Hey man. Appreciated

    Its not a hiccup though.   There is no issue at all. It works

    I'm merely saying that the software and documentation MISLABELS the default shortcut for timeline expansion.

    When you work with Blender, for example, the keyboard shortcuts clearly indicate Num 1, Num 2, Num 3, instead of just 1, 2 & 3.


     

This discussion has been closed.