How to glow particles while 3D space keeps instact?

Majahr
Majahr Website User, HitFilm Beta Tester Posts: 559 Enthusiast
Hi.
I know this question has been asked before, but what's the solution? I've a composize shot like this:
(1) Camera
(2) Grade (with glow effect)
(3) 3D Plane (with simple mask)
(4) Particles
The particles are turned around the plane. Everything it's fine as long as the grade is above both layers (plane & particles). But what to do, if I only want to glow the particles? If I move the grade layer at position (3), only the particles will be glown, but the 3D position will be lost, too:
[img]http://www.monkeybits.de/HitFilm/forum/images/3dgradeproblem.jpg[/img]
This problem will be also not solved, if I transfer the particles to it's own composite shot and embedded it as 3D unrolled...
Any idea yet?
Thank you,
Marc

Comments

  • Robin
    Robin Website User Posts: 1,671 Enthusiast
    Replace the particle layer with a composite shot which holds the particle system and the grade layer, and in the main comp shot, turn the comp shot with the particles to "3D unrolled". This should do the job...
  • Majahr
    Majahr Website User, HitFilm Beta Tester Posts: 559 Enthusiast
    [quote]This problem will be also not solved, if I transfer the particles to it's own composite shot and embedded it as 3D unrolled...[/quote]
    I forgot to tell you, that I've moved the grade layer also to that new shot, but the particles lost the 3D position...
    Regards,
    Marc
  • Robin
    Robin Website User Posts: 1,671 Enthusiast
    Did you also put the grade layer into the new composite shot and remove it from the original one?
  • RodyPolis
    RodyPolis Website User Posts: 613
    Ya I asked that question last week, and I think the answer was you can't be grading particles and keep everything in true 3d. So what you and I are trying to do won't work the way we want it to.
  • Majahr
    Majahr Website User, HitFilm Beta Tester Posts: 559 Enthusiast
    edited July 2011
    Thank you Rody...
    ...I hope, FXhome will fix this behaviour, otherwise, you can't grade the particles w/o loosing there 3D position if a corresponding 2D-layer shouldn't be graded...which is a unsightly restriction...
    Regards,
    Marc
  • IamJoshuaDavies
    IamJoshuaDavies Staff Administrator Posts: 359 Staff
    This isn't a bug, more an annoying quirk of 3D compositing with 2D grading applied.
    The only option would be for the software to grade every particle individually which would produce a massively different result to grading the particles as a whole. This method would also be monumentally slow to render.
    Depending on your intended results the only methods are the same as one would have to use in After Effects. That is to split up your composition with masks and grade the different layers individually.
  • Majahr
    Majahr Website User, HitFilm Beta Tester Posts: 559 Enthusiast
    ...but what's the best way then to modify the ermitted particles...? I can't do everything with the available properties like color, alpha, ... If I need a little bit glow or blur, the only way I know is to use a grade layer above my particle layer. I don't know, if there's an easier solution, but it would be cool to be able to add effect to the particles...like I do with 2D layers.
    Regards,
    Marc
  • IamJoshuaDavies
    IamJoshuaDavies Staff Administrator Posts: 359 Staff
    You could add individual particle glow by duplicating your particle engine and using a larger blurry/fuzzy version of the particle texture then setting the blend mode to add.
  • Majahr
    Majahr Website User, HitFilm Beta Tester Posts: 559 Enthusiast
    Hi Joshua.
    Yes, you're right...that could work...thank you...but it's only a workaround...you still can't use any effect bundled with HitFilm yet...but okay...maybe one time... 8-|
    Regards,
    Marc
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!