Newly installed HitFilm Express freezes up immediately upon opening

I've just install HitFilm. Upon opening it, a window opens that has a HITFILM EXPRESS menu along the top, but everything else below the menu is white, and I can't interact with the menu. The wait cursor appears, and never goes away. After several minutes I killed the process and tried again, but it happened when I tried again. I reboot, and it's still happening. I uninstalled and reinstalled the application, but it's the same thing. 

I have an Alienware R4 with a GTX 1070 graphics card. Intel i7-7820HK CPU, 16GB of RAM. This happens every time I open the application. I seen errors in the event viewer. I disabled antivirus to see if it changed anything, but it doesn't help.

Any advice to further diagnose what's happening?

Thanks,

-Dan

 

 

Comments

  • Triem23
    Triem23 Posts: 20,069 Ambassador
    edited July 2018

    This is an issue with Dell's Backup utility. It's got its own FAQ. 

    https://fxhome.com/faqs/view/78

  • I don't appear to have either of the applications listed in that link installed on my machine. Does this software perhaps go by any other names? In my Add/Remove programs (Apps & features on Win 10), the only program with "dell" in the name is "Dell SupportAssist". And the programs with Alienware in the name are:

    * Alienware Digital Delivery

    * Alienware Command Center

    * Alienware Customer Connect

    * Alienware Graphics Amplifier Software Installer

    * Alienware On-Screen Display

    * Alienware Product Registration

    * Alienware Update

     

    Thanks.

  • Triem23
    Triem23 Posts: 20,069 Ambassador

    Dan, I don't own an Alienware to check. I'd say contact support directly. Let them know you've read the FAQ linked above and the list you just posted - that way they don't ask you to repeat what you've already done. Offhand I'd say your guess the software might have been renamed is solid. 

    https://fxhome.com/questions/submit

    FYI-Mods aren't FXHOME staff, we're just users allowed to delete the occasional spam we find. So, once we get past referring to FAQ 78, not much more we can do to help. 

  • Thanks. I didn't see that as a support option originally, hence this post. I've submitted a support ticket. Thanks for pointing me in the right direction.

This discussion has been closed.