2D Tracking not working properly

KayEm Posts: 9 Just Starting Out

Hi all, 

In the last three projects I have worked on, I've found that 2D tracking simply is not functioning. I have tried every single conceivable combination of settings and nothing has worked. This is extremely frustrating as I love using tracking for slick-looking animation but I just cannot get this to work. Please help!! See the link below for an example. That one was done with default settings. I have tried choosing larger objects to track in this shot, and I've tried picking smaller objects, but nothing works.

2D Tracking not working


  • Triem23
    Triem23 Posts: 20,601 Ambassador

    Tracking looks for a point of contrast. Instead of picking the center of a gray square (low contrast), try grabbing one of the CORNERS of that square where it meets the brighter dome (high contrast)?

  • Palacono
    Palacono Posts: 3,423 Enthusiast

    It should easily track that. I've just tested tracking some very pale clouds against some other clouds.  Both Optical flow and Template Match worked, although Template match tracked worse things for longer.

    Go into Tracker Options next to where it says Optical flow and reset the the % and iterations and try again.

    If that doesn't work, then change from Optical Flow to Template Match, where I just managed to track a virtually white section of cloud against another section of cloud. I could barely see the difference, but it could.

    It almost looks like it's drifting off due to scale and not just losing the points. Is the video clip the same size as the project settings and has the same frame rate?

This discussion has been closed.