Not responding when opening HitFilm Express

noyrocks2017noyrocks2017 Website User Posts: 15

Hi Guys

I just installed hitfilm4express. When I open it it open. But when I click "New" it starts the spinning wheel, freezes and comes up with not responding. I recently upgraded to Windows 10. it worked well when i used it on Windows 7.

 

My specs are:

Windows 10  Home 64bit

i3-3240 @3.40GHZ

Intel HD Graphics

Comments

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,275 Ambassador

    Your machine is under minimum spec to run Hitfilm. Hitfilm wants an Intel HD 4000, your i3-3240 only has an HD 2500. You might have been lucky with Windows 7, but Windows 10 is more resource-intensive and seems to be eating up whatever resources were letting Hitfilm run.

    Sorry, I know this wasn't the answer you wanted to hear.

  • noyrocks2017noyrocks2017 Website User Posts: 15

    Thank you for this help. So there is no way around this?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,275 Ambassador

    Probably not on your current machine. You didn't list your RAM. That might be a factor. It's likely you have 4GB, but Microsoft recommends 8GB for Win 10. 99.95% certain any solutions begin with "get a new computer."

    You could try contacting Support directly (Forum Mods are not FXHOME staff. We are user volunteers), but the chances are they would have the same answer. Unfortunately if your hardware is under the minimum listed specifications to run the software you cannot expect the software to function correctly. 

    Again, I'm sorry and wish I had better news. 

  • noyrocks2017noyrocks2017 Website User Posts: 15

    I  have 8gb ram

This discussion has been closed.