Hitfilm freezing almost immediately upon starting after working fine for the first couple weeks

braddg
braddg Posts: 3

I've seen several topics addressing this issue, and I seem to be different from the ones I've seen in that I'm not trying to do anything new, and Hitfilm has worked fine for me until the past week or two. I tried to understand the solutions  that were given for other people having this problem, but I didn't understand any of the technical jargon that was used.

Even though it worked for a while, Hitfilm Express now freezes whenever I try to open anything or start a new project, and sometimes within seconds of opening the program, before I'm even able to do anything. I don't understand how it can work fine for a while, to the point where I'm even able to create a small project without issues, and now it's totally unusable.

Comments

  • braddg
    braddg Posts: 3

    I swear I gave the system information when I posted this.

    OS: Windows 10 64-bit

    CPU: Intel(R) Core(TM) i5-3320M CPU @ 2.60Hz 2.60GHz

    GPU: Intel(R) HD Graphics 4000

    RAM: 4.00 GB (3.70 GB usable)

    It sounded like I meet the requirements from what I read somewhere on the Hitfilm website.

     

  • Triem23
    Triem23 Posts: 20,079 Ambassador

    First thing to check is that you've run outstanding Windows updates. 

    Second thing to check is that your GPU drivers are current. 

    Ironically Windows Update can cause problems with GPU drivers. Sometimes a Windows update rolls the GPU drivers back to an earlier version. 

    You are right at minimum spec for Hitfilm. Are you having issues with all projects, or one in particular. 

  • braddg
    braddg Posts: 3

    I updated Windows, then checked my graphics card and it was already up to date. I cleared out the cache for Hitfilm too. But after doing all that and restarting, it still freezes when I try to open the program. I don't get how it could be the fault of my computer, considering Hitfilm Express worked perfectly for the first couple weeks. I didn't do anything differently that should have caused this to happen, especially since everything else works perfectly fine on this computer.

This discussion has been closed.