3d effects dissapear when light added

ok I might just be misunderstanding how some of the things work but I am an working on a composite shot. I have two 3d space ships  and a dead planet.  I am using a star feild jpg as my lowest layer as back ground.  I Add a light  to make the scene look more real but then I added the phaser preset and when the light is on I can't see the phaser but if I turn the light off I can see it. Is there a setting I need to change in the phaser or with the light when using the phaser?

Comments

  • rgbii
    rgbii Posts: 965 Just Starting Out
    edited December 2013
    Hi Diabloogre,
      I haven't used the phaser before, but taking a quick look, it doesn't seem that it produces any light of it's own.  Try this (it might work depending on how you setup your light), in the phaser's 'Material' controls, click on 'Billboarded Lights' and it should show up.
    In Hitfilm, if you haven't added any lights, every thing gets light up by a built in ambient light.  Once you add a light, it assumes you want to light everything youself, so the built in ambient light is removed. 
    Instead of using the previously mentioned Billboarded light, you could instead make sure a light is hitting the phaser.  For example, if you pull the light you added so that it is between the camera and the phaser, it should be visible.
    Another option would be to add another light, set its type to ambient and set it low. This way everything will have at least some light on it, keeping it visible.
    Hope that made sense,
    Richard.
  • SimonKJones
    SimonKJones Posts: 4,448 Enthusiast
    Richard is correct - the reason the phaser is disappearing is literally because no light is falling on it. As soon as you start adding 3D lights, you need to be aware that objects will not be visible if they're not being lit - just like in real life.
    The extra complication with particle effects is that particles are 2D textures, even if the particle effect itself is 3D. Therefore you can have a situation whereby the particles are 'side on' to the light, rather than face-on. The billboarded lights option that rgbii mentioned fakes the particle lighting so that 3D lights always light them as if they're face-on. The billboarded shadows option is similar.
    Bit tricky to get your head around, but useful once you have. :P