Ignite express 2017 help

bbeliason
bbeliason Website User Posts: 18

Hey! I downloaded ignite express 2017 today, and I was wondering if it put all the plug-ins on to hitfilm 2017 express, or if it is a separate program.

Comments

  • NormanPCN
    NormanPCN Website User Posts: 4,043 Enthusiast

    Ignite Express does nothing for Hitfilm. The effects in Ignite are already in Hitfilm. Ignite is for other editors. The Ignite Express web page lists the supported editors.

  • bbeliason
    bbeliason Website User Posts: 18

    thank you so much

  • LenKaufman
    LenKaufman Website User Posts: 2
    edited August 2017

    Hi all. Saw Ignite Express mentioned on Magix Vegas Pro forum. Signed on with HitFilms and downloaded Ignite Express Installer. Double clicked on the msi file, and essentially, it produces another copy of the same file in the download page. Clicking again and I'm in an endless loop of creating/clicking/creating file etc. Also tried right clicking and opening containing folder, clicked on the file there, and got same result: another copy of the msi file. I'm not new to the concept of downloading and installing programs and files, but this one has me flummoxed. I never get to the install sequence. Any suggestions? Thank you. (Windows 10)

     

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,798 Ambassador

    @LenKaufman that's abnormal behavior. Running the .msi file should proceed directly to install. Perhaps something glitched in your initial download? 

    Try re-downloading? 

    https://hitfilm.com/ignite-express

     

  • LenKaufman
    LenKaufman Website User Posts: 2

    Hi Triem23.  On the Vegas forum, I posted the same question, and someone suggested that I delete history, cache, etc., and reboot. I did all of that, and additionally, deleted all of the many Ignite MSI files. Downloaded new MSI file. Same problem. Perpetual loop of  double click, download, double click. 

    Any other suggestions?

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,798 Ambassador

    @LenKaufman at this point I'd say contact support. My installation worked perfectly the first time. I tried an uninstall, grabbing the current download package and re-install and had no issues. Sorry I couldn't be more helpful. 

    https://hitfilm.com/questions/submit

This discussion has been closed.