Crashes and glitches!!!!

Docheadzstudiospez
Docheadzstudiospez Website User Posts: 1

I have been kinda disappointed in the new express software. It glitches like crazy and I have lost like 10 hours of work because it won't open one of my projects after I updated it. Also, it crashes even while doing basic editing. I am sad to say that Hitfilm Express 4 worked better...

Comments

  • CleverTagline
    CleverTagline Moderator Las Vegas, NVModerator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,305 Ambassador

    @Docheadzstudiospez - It's possible that the problem lies in your system.  Many users (myself included) have been using the new version extensively since its release, so I would expect a much greater outcry if it were truly a problem in the software.  Make sure you have the latest video drivers for your system, and that your system meets the minimum specs outlined by HitFilm on their web site.

  • WillDouglas
    WillDouglas Website User Posts: 4

    I was using Hitfilm 4 Express very successfully, upgraded to Express 2017 and purchased 3 upgrades, everytime I drag video to the timeline it crashes instantly. I currently can't use it at all and I'm down £53 into the bargain. As far as I can tell, there is certainly a problem with Express 2017 @jsbarrett.

  • Film_Empire
    Film_Empire Website User Posts: 179 Just Starting Out*

    @Docheadzstudiospez and @WillDouglas

    I have been using Hitfilm Express even before its release and I'm running it succesful with several add-ons. Your C: disk is probably too full for Hitfilm to store temporary files. Try leaving 10% of your disk clear for temporary files and see if that helps...

  • WillDouglas
    WillDouglas Website User Posts: 4

    I have 329GB free hard disk space. It opens fine, I can add jpg and BMP files over no problem, when I try any type of  video file as soon as I try to drag it to the timeline it crashes instantly, do you have any solutions @Film_Empire ?

  • Film_Empire
    Film_Empire Website User Posts: 179 Just Starting Out*

    @WillDouglas

    Hmmmm... Strange. I would open a support ticket if I were you.

    @Triem23 Any solutions?

  • Fire_Rice
    Fire_Rice Website User Posts: 1

    Does anyone know how to fix distorted export and the 3 seconds of black in every export? I REALLY need help and fast

  • triforcefx
    triforcefx United StatesModerator, Website User Posts: 1,261 Moderator

    @Fire_Rice I'm not entirely sure why you're commenting on this particular thread... But I'll try to help.

    When you hit the export button, are you exporting In-Out Area or Contents? For the most part, you'll want to export Contents. Try doing that and see if you lose the extra black.

    As far as the distortion, what are your system specs? What effects are you using?

This discussion has been closed.