The website

Reviolitaztegoud
Reviolitaztegoud Website User Posts: 3

For some reason the hitfilm website is broken. When I press menu nothing comes up, I get to the hitfilm 4 express part of the site try to see if i get the free license there nothing happens when i press "get hitfilm exress free". Can anyone help?

Comments

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,418 Ambassador

    What browser are you in? I've just stepped through the entire site on Opera for Android and Firefox for Windows and everything works for me. 

  • DanielGWood
    DanielGWood Website User, HitFilm Beta Tester Posts: 1,021 Just Starting Out

    @Reviolitaztegoud

    it sounds like you have javascript disabled, or are using something like NoScript. If the latter, you'll need to allow hitfilm.com and googleapis.com.

  • Reviolitaztegoud
    Reviolitaztegoud Website User Posts: 3

    I use google chrome. I just tried firefox after reading your comment and that didn't work. I checked the the website secure connection and and it was allowed by default

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,418 Ambassador

    You might need to contact support. 

    I've stepped through the entire website on Firefox for Windows and Opera for Android, including a download of Express. Everything is working at my end--and I think if the site were truly broken we'd have a lot more posts about it. 

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,418 Ambassador

    Helps if I paste the link. 

    https://hitfilm.com/support

     

  • Reviolitaztegoud
    Reviolitaztegoud Website User Posts: 3

    Sorry for wasting your time with my idiocy. I tried to get the code on my mom's computer and it worked. I guess it will remain a mystery why my pc couldn't show it. I will delete this discussion tomorrow. I will keep it today as a apology

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,418 Ambassador

    No need to apologize. Glad you're up and running. Happy Hitfilming! 

  • DanielGWood
    DanielGWood Website User, HitFilm Beta Tester Posts: 1,021 Just Starting Out

    No problem.

    We've seen a couple of people recently who've found the website doesn't work due to a bit of malware on their machines, which inserts broken tracking code into websites they are browsing. This broken malware then breaks our site.

    So, it is worth running a quick scan on your PC at some point in case you're affected by something like this.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!