3d model texturing issue

Hi all,

Downloaded the celestial model pack with a view to making a rotating earth. Imported 3d model and attached textures without any issues. The problem is that what I see on the preview window isnt what I'm getting in the main composite shot. The 3D preview has appropriate bumps and textures while the same 3D model in the shot is flat and lifeless (although correctly coloured).

Any ideas?

Comments

  • inScapeDigital
    inScapeDigital Posts: 709 Just Starting Out*

    Have you added a Light in the composite shot?

  • GrayMotion
    GrayMotion Posts: 1,598 Enthusiast

    Yes. Lights first.

    Then turn on ambient occlusion for the model. 

    Cheap Tip: Use the diffuse map texture (1_earth_8k2.jpg) for a bump map. Turn bump up to two (2). It will give you a nice texture contour. This will bump all whites up and push blacks down.

    Once you add the upper cloud layer(s) and atmosphere you'll have yourself a decent looking Earth.

  • Triem23
    Triem23 Posts: 20,065 Ambassador
    edited April 2017

    Do you have any 2D image, plane, video or grade layers between your model and lights? If so, move lights past the the 2D layer, next to the model. 

    This blog post from a Hitfilm dev goes into detail as to why. 

    https://hitfilmtips.wordpress.com/2012/03/09/tip-render-order/

  • OK lots to think about. Lights first, got it. I'll revert once I've tried that:)

  • Stargazer54
    Stargazer54 Posts: 3,425 Ambassador

    And, as suggested by Triem23 many times.  Its a good idea to create a generic file that already contains a camera and lights (and maybe a parent point to attach your model to).

    Once you save your basic set up file, then every time you want to work with a new model, you simply open your base file, import the 3D model and parent to a point for rotation/translation.

    With lights already in place your can immediately start tweaking materials.

  • Doing a bit of work on this today. Does anyone have an idea why I can see the planet on a star field background, set orbiting target and everything looking good until I add an ambient light at which point the earth disappears (becomes a round black void where it used to be)? I can still see it normally in the preview window and I have checked that the ambient light is visible and cranked all the way up too 100%. I can add further spotlights around the earth which light up small segments but it seems the ambient light option is actually creating an ambient darkness. Any ideas?
    Thanks again,

    Donald

  • Aha, set 3d materials to something other than black, got it, never mind.

    Steep learning curve this business....