2D Tracking is not working properly in Pro 2017

CedricBonnierCedricBonnier StaffAdministrator, HitFilm Beta Tester Posts: 1,189 Staff
This discussion was created from comments split from: [NEW BLOG POST] HitFilm Pro 2017. It's here..


  • jaajaa Website User Posts: 73 Just Starting Out
    edited March 2017

     Recently upgraded to hit film pro 2017 , but i am having problem with the tracking I can't track any video clips , i  am not suer if anyone else  got this problem , I update  ,uninstall the HF and re stall still is not working  , I tried  it with Hitfilm 2 it is working and also i tried with hit film 4 (DEMO ) it is working fine, I use Mac, so any help  to fix this problem appreciate.

  • CedricBonnierCedricBonnier Staff Administrator, HitFilm Beta Tester Posts: 1,189 Staff

    @jaa I've created another thread for your issue, this is generally the best thing to do to help us keep track of current issues.

    What exact version of HitFilm are you using? HitFilm Pro 2017 Update 3 should have improved 2D tracking, please let us know if this is not the case for you.

  • PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast
    edited July 2017

    @CedricBonnier in what way is 2D tracking improved in Update #3 There is no mention of a fix in the release notes other than not crashing  ."..when creating a composite shot from a layer that had been tracked in mocha".

    BTW, it still has the sub-frames inaccuracy bug that was introduced in Hitfilm 4 and as detailed in my video for bug #44 in this thread: https://hitfilm.com/forum/discussion/comment/89428/#Comment_89428

    And it is a bug, as you'll see from the end of the video for '#44 Loose Tracking Bug" with points being offset by large amounts when combined with more accurate tracking data from the same tracked point.

    Currently the only way to apply an accurate Transform to a Point is to Stabilize the video, cut'n'paste the tracking data directly to the New Point, then reset the stabilisation, as the data gets snarled up by the Transform... or to use HF2E (if you have it) to do the tracking because that Transform works perfectly.

  • shaggy2922shaggy2922 Website User Posts: 1

    I'm having similar issue, whenever I try to track anything, it just stays in in one position, no matter what the video showed

  • DreamArchitectDreamArchitect Website User Posts: 595 Enthusiast

    Me Too. Track forward and back only move one frame and don't track the footage. The track box just stays in place and I have to keep clicking the track forward button as it keeps stopping after one or two frames. Either way it doesn't track as it should.

  • DreamArchitectDreamArchitect Website User Posts: 595 Enthusiast

    Ok I've now done a bit more research and I can track some footage but other footage seems to cause it problems. I have some footage downloaded from youtube of riots. two different clips show tracking issues. I have another piece of footage from you tube that is a close up of an eye and that tracks fine.  I am not sure there is in fact a bug. I think it might be related to the particular footage. It does seem more temperamental that is was before though. It just doesn't feel quite as reliable to use.  Not really something I can quantify but in hf4 pro it only failed to track once in the time I used it. I only had a 50-50 success just testing hf pro 2017 latest update right now.

  • PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast

    There is a lot of adjustment you can do with the tracking. You can track the motion, which is using optical flow, so it handles things changing shape, but needs some contrast to follow well; or you can track the actual shape if it doesn't change but doesn't have a lot of contrast. You can also play with lots of different ways in which it processes the image to do the tracking. Play around until you get something that works for the particular footage. 

    I recently had to track some clouds which were light grey on dark grey and the default settings just couldn't cope, but with a bit of experimentation: locked right on to them and worked just fine.

  • DreamArchitectDreamArchitect Website User Posts: 595 Enthusiast

    @Palacono you may well be right, I was literally just throwing footage at it to see if it worked at all. 

This discussion has been closed.