3D Model not in 3d space

Ive just put 2 3D model in a comp they don't seem to be in the 3d space more in the order of layers when I rotate round.
I know I can nest them in one model and it work but then I can't add effects to the models individually. am I missing something or is it just implement it poorly at the moment?.

Comments

  • AxelWilkinson
    AxelWilkinson Posts: 5,255 Staff
    This is by design, and is how the 3D model import works.  Each 3D model layer will exist in its own 3D space.  Combining models into a single layer will put them in the same 3D space, keeping them on separate layers will separate them, allowing you to use the layer order to control how they are composited.
  • cowdar
    cowdar Posts: 39
    Thanks for answer so It not possibly to have effects like shatter on individual models if they are on the same layer.
    eg I have 2 models gasses with the camera doing a full circle round them I want to shatter them individually.
  • cowdar
    cowdar Posts: 39

    Its a shame they don't have a option to add elements to the same 3d space.

  • Triem23
    Triem23 Posts: 20,279 Power User
    What you can do is "split" the back object layer when it comes to the front and move it up higher in the layer stack. That's a workaround. Also note that Hitfilm "flattens" everything below any 2D layers you add. This is also by design.