Image is cropping when I place it on the timeline

I have been having problems with images getting cropped. The original image is 3840x2160 and when I place it on the timeline it gets significantly cropped, even when I resize it. Any ideas what I'm doing wrong?

The original look of the image:

 

 

What happens when I place it on the timeline and scale it down:

Comments

  • CedricBonnier
    CedricBonnier Posts: 1,198 Staff

    Hi @Xorgon, here are a few questions to help us diagnose what went wrong:

    1. Does the image look right in the Trimmer panel?
    2. Are you dropping your image in the editor sequence or a composite shot?
    3. How are you resizing your image?
    4. Could you put a screenshot of your entire HitFilm interface please?
  • Xorgon
    Xorgon Posts: 7

    1) The image looks correct in the trimmer.
    2) I have tried it in both the editor sequence and a composite shot.
    3) I've tried both by hand and by using the "Transform" section when the image is in a composite shot.

    4)
     

     

    I also did some experiments with cropping the image down outside of Hitfilm. Reducing the height seemed to stop this cropping problem, however that workaround doesn't allow me to use the whole image.

  • Triem23
    Triem23 Posts: 20,080 Ambassador

    It's a vertical image. You'll likely have to scale it down a lot more ti see all of it, and you'll have a lot of black on the sides. 

  • CedricBonnier
    CedricBonnier Posts: 1,198 Staff

    @Xorgon could you please upload the original image so that I can try here?

  • Palacono
    Palacono Posts: 3,423 Enthusiast
    edited July 2016

    You say the image is 3840x2160, but show something that is taller than it is wide in the Trimmer, but say that that it looks correct there.

    You sure it's not 2160x3840 and the camera was turned sideways, because that would make more sense?

    Anyway, as it's bigger than the project (I'll assume 1920x1080p) then you're only going to see the centre portion unless you scale it down to fit.

    If it actually was 3840x2160 then that would be exactly 200% larger than a 1920x1080 frame and you'd just set the scale to 50% to get it to fit perfectly.

    As it's apparently turned sideways, then you'll have to adjust the scale until either the top and bottom touches the frame edges (28.2% and you have black borders at the sides), or the sides touch (88.9%) and you lose the top and bottom of the image, but you could show that by using keyframes to pan from the top to bottom of the image over a few seconds.

  • BobDiMarzio
    BobDiMarzio Posts: 630 Just Starting Out

    Ok, I place a 3840x2160 image into 1920x1080  composite and rotated the image so it would be in the vertical orientation.   In order to see the entire y axis (long end 3840 pixels) I had to scale the image down to exactly 30%.

  • Xorgon
    Xorgon Posts: 7

    It appears I made a mistake in my original post, the image is supposed to be vertical, as in my screenshot.

    @Palacono , I was using the scale down feature the checkerboard pattern is the background. Large portions of the image were removed.

  • Palacono
    Palacono Posts: 3,423 Enthusiast

    @BobDiMarzio, your viewer window must be zoomed in, because the scale should be 50% as it's exactly 200% bigger. 

    On a1280x720p project the scale would be 33.33% to fit.

  • BobDiMarzio
    BobDiMarzio Posts: 630 Just Starting Out
    edited July 2016

    @ Palacono if the orientation was Horizontal (Landscape) then it would be 50% however if you import the image in the Vertical (portrait) then the scale factor will be 30% in order to see of the image. Of course there is a significant empty border on the left and the right but the issue was remove the scaling.

  • Triem23
    Triem23 Posts: 20,080 Ambassador

    I believe the solution is to make custom composite shot dimensions of 1080 x1920. Which Hitfilm can't do. Or, rotate the image 90 degrees and work sideways. 

  • Palacono
    Palacono Posts: 3,423 Enthusiast
    edited July 2016

    @Xorgon , So that's as it should be. You can't fit a tall thin image into a short fat window.

    Well, you can, but you get a lot of borders at the sides. As I said above: scale is either 28.8% with borders or 88.9% and you pan and scan over the image.  Or decide how much you want to lose and how big a border you want and pick somewhere in between those values.

    http://i854.photobucket.com/albums/ab106/pickaname2/touchtopbottom.jpg

    http://i854.photobucket.com/albums/ab106/pickaname2/touchsides.jpg

  • Palacono
    Palacono Posts: 3,423 Enthusiast

    @BobDiMarzio, oh I see you were just rounding it up. Yes, it's 28.8% to not lose anything.

  • Xorgon
    Xorgon Posts: 7

    Sorry, I wasn't very clear. I'm not having problems with it overflowing, I know about scaling and have used it before. The problem is not trying to remove the empty space on each side. When the image is placed into the composite shot there is overflow and I have scaled it down to view the whole image on the previewer. However, when I do scale it down parts of the image are completely missing, note where the image border resize box is on my image.

  • BobDiMarzio
    BobDiMarzio Posts: 630 Just Starting Out

    Wow, this is interesting.   I took Xorgon's photo and imported it into Hitfilm 4 Express and I got the same effect that Xorgon did.   I then went to the file in my directory, opened it in windows photo viewer, rotated it by 90 degrees.   I then imported the rotated photo into HF4E,   Moved it into a composite shot, rotated it back by 90 degrees (back to the vertical)and scaled it down by 30%.   Now I see the entire image.

    Give it a try.

  • AxelWilkinson
    AxelWilkinson Posts: 5,252 Staff

    It sounds like the image rotation is a bit wonky, and the pixel data is getting rotated, but the pixel dimensions aren't. Can you open the image in an image editor, save a new copy of it, then import that copy into HitFilm and see if it still has the same issues?

    Can you click on the HitFilm logo in the top left corner of the interface to open the splash page, and check what specific version of HitFilm 4 Express you are running? 

  • BobDiMarzio
    BobDiMarzio Posts: 630 Just Starting Out

    Here is what it now looks like after I rotated the image Before importing And then re-rotated after placing into a composite

    https://s32.postimg.org/icq62cn79/Capture.jpg

  • Xorgon
    Xorgon Posts: 7
    edited July 2016

    Re-saving it, ensuring the proper orientation, fixes the problem. Thanks!

    I am using Hitfilm 4 Express, 4.0.5227.37263 (Update 5)

  • CedricBonnier
    CedricBonnier Posts: 1,198 Staff

    @Xorgon Your issue does look strange and it could be a bug in the software, I'll have a look tomorrow. It may have to do with the fact that the image has a rotation in the EXIF data.

    As others stated, in the meantime you can rotate your image in any image editing software (paint would do) before importing it to HitFilm.

    As a side note, the current version of HitFilm 4 (Pro and Express) is Update 6. Even if it won't change the behaviour on this particular issue, it is generally a good idea to keep the software updated ;)

  • I've been having the same issue:  Importing  a large portrait image (from an Apple phone) into a landscape format and finding that although the image looks OK in the trimmer, as soon as it is placed on the time line Hitfilm has cropped the image and altering the scale and viewer zoom does not recover the cropped areas of the image.  I had tried adjusting the image in a photo editor down to a smaller sized image (so small that it in fact was pixilated and unusable) but still had the same cropping effect.  I will try another editor tonight (Paint as suggested) and report back.

  • i believe im having the same problem 

  • The solution I used:
    1) Open your image in an image editor, I used GIMP.
    2) Ensure the image is in the correct orientation, you may need to rotate it.
    3) Once the image is in the correct orientation, export it.

    It should now appear properly in HitFilm. I think the original error occurs when HitFilm can't properly handle rotation in the image data.

  • IVBakker
    IVBakker Posts: 1
    edited January 2017

    Any update on this? I've got 20 pictures. Double rotating is going to take a while...

  • I also have the same problem. Seems to be a general bug. The image shows up correctly in the trimmer, but shows up cropped the wrong way when inserted into the timeline. I have several pictures and it does the same thing for all of them. Is there a way to fix this?

  • Triem23
    Triem23 Posts: 20,080 Ambassador

    @IVBakker @NomadApe Well... as long as the bug persists, the fastest way to fix the issue in Hitfilm is to load in all images. Then create a point layer. Parent all images to the point layer, then rotate the point 180 degrees. This flips all images in one operation. Then you can delete the point.

    As Xorgon pointed out, GIMP is a great, and free image editor that can also batch and save your images.

  • LeslieD
    LeslieD Posts: 1

    I am having the same problem and I am using jpgs. IT looks great in the trimmer but crops the shizz nizz out of the pic when I put it in the timeline.   This is making me insane.  I want to do time stop but if I have resize in a  different editor all the time Im going to light my hair on fire. IT will be completely impossible to get this thing lined up in a usable way.  Why can't I just shrink the frames to fit inside the pic.  This makes the software completely and totally unusable.   I want to post a pic here but now it is asking me the dimensions of my jpg.  WHAT??  That should be for the most part immaterial    What are people doing about this. ????????????????  Many Pics I use are too big but it doesn't crop them like it is doing sometimes and not others.   I can't do my projects. I can't make it work with this problem.  I tried to post the regular jpg here but it won't accept it. 

  • Triem23
    Triem23 Posts: 20,080 Ambassador
    edited June 2017

    @LeslieD Hitfilm's default behavior is to import images at 100% of their size. Some users don't want this behavior. Changing the behavior to auto scale would make the rest of the users unhappy. 

    Now, you didn't read this thread which discusses multiple ways to rescale images.

    First, on the Editor Timeline, right-click your images and select a scale option from the context menu. 

    Second, in an Editor or Composite timeline adjust the scale of your images in the layer property controls. 

    Third, in a Composite Shot, load several images of the same size, parent to a point and adjust the scale of the point to resize all images. This really only works if you're editing in that Composite Shot. 

    Fourth, in the Editor or Composite timelines, highlight the image, reduce viewer scale, hold Shift, and drag the control box to rescale (Shift locks aspect ratio. 

    Fifth, batch rescale in an outside program. 

    So Hitfilm has four ways to shrink your images, one to directly scale to your comp size. When you ask why the software doesn't have the option? Yeah, it does. :-) 

  • right click on the image in the timeline. go to transform and click fit to frame. It worked for me.