I made a png with a transparent background, but it in hitfilm it has a black background...

adam6e
adam6e Website User Posts: 2

HI.

Im creating a number of videos following the same design.  I have completed 3, and am working on the 4th.

The first three, I was able to add my transparent images and they appeared... transparent. 

In this video, when I add a transparent image, they appear with a black background.  I even added images from the previous 3 movies, and they all appeared black in this movie.

Is there a setting that I am missing?  All of the other movies required no keying, nothing.  Just the transparent image.  But this one is screwing me up.  What on earth can the issue be?

Comments

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,935 Ambassador

    Right-click the ones coming in with the black bg and select properties. From there look for a setting for Alpha and make sure it's set to premultiplied. 

    You're using the exact same files imported for the first three movies? 

  • adam6e
    adam6e Website User Posts: 2

    Where should I right-click the image?  Wherever I click I don't see alpha listed in its properties.

    Yes, I have tried the other images that were successfully imported into my other movies, and they too render in the movie, and the movies preview with a black background

  • GrayMotion
    GrayMotion Website User Posts: 1,591 Enthusiast

    If you go to the main media that you imported and then right click / properties you should see a Aspect ratio box and a Alpha box

  • cielke
    cielke Website User Posts: 4
    edited April 2017

    Hi Guys,

    I have the same problem here. I loaded this image to my project:

    glasses link

     but when i import it the background gets black

    imported

    there's aspect ratio but no alpha option...

    i tried a couple of other .png but all come up this way. What seems to be the case ?

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,935 Ambassador

    To clarify, have you put the PNG files over any other layers? You might have checkerboard off?

  • cielke
    cielke Website User Posts: 4

    wow, that's a fast reply.

    yep, checkerboard off, it comes out as a black rectangle on the viewer:

    ckecherboard off

  • cielke
    cielke Website User Posts: 4

    Hi Guys,

    it appears that the image (images!) were faulty. I received a corrected one via PW.

    Unfortunately don't know how to deal with it in the future, is it possible to correct it with GIMP / paint.NET or any other free software... and the main question - how to do it ? :)

    Thank you!

  • colamanBS
    colamanBS Website User Posts: 92 Just Starting Out*

    Sorry dont know all technical words in English, i am german.

    I used Affinity Photo (Photoshop or something may also work).
    Affinity Photo is for Mac and PC, think there are Test-Versions available.
    Opened the PNG and exported new PNG.
    Not as "hole document", export "selection without Background".
    Thats all

  • ConstantinStan
    ConstantinStan Website User Posts: 1
    edited May 2017

    Hi guys,

    Here my method to solve this: I put the png file in PaintNet, I saved in JPG file and then I remove the background, save again in png, and works :).

    Hope this help you!

  • Leandervanhulle
    Leandervanhulle Website User Posts: 1

    You need to save your PNG as 32-bit.

    24-bit png images get a black background.

    You can do this with Paint.net

  • AISARAKMAL
    AISARAKMAL Website User Posts: 1
    edited March 2018

    i have the same problem with CIELKE....why the black glasses we can only see the white part..please help me....Thank you in advance

  • cielke
    cielke Website User Posts: 4

    Hi AISARAKMAL,

    as it goes for the particular image you can get it here. It's the same picture but saved "without background" - thanks to colamanBS :)

    if you need to convert another image try just opening it in some software  like: Photoshop/GIMP/Affinity/PaintNet and exporting again as 32-bit png.

    cheers

     

  • mishu36
    mishu36 Website User Posts: 1
    edited October 2018

    PNG image export problem

    Reading all the comments above it seems to be there was a problem in the export setting of the image.

    Photoshop: When you are trying to export a PNG image with photoshop it will automatically export the alpha channel data along with the RGB channel.

    Gimp: when you try to export the image in PNG format in gimp then you will have to select any RGBA profile (In the "export image as PNG" dialogue box click the dropdown list that says "automatic pixelformat" and select any RGBA profile).

    This should solve the problem.

    R = Red

    G = Green

    B = Blue

    A = Alpha (this channel holds the data related to background transparency .)

     

  • CooljaNitez
    CooljaNitez Website User Posts: 1
    edited May 2019

    Having the same issue with images from google images that are PNG format with transparent backgrounds. When I drag it to my media dock to the timeline it has a black background. So annoying. Im using Hitfilm Express 12. 

  • tddavis
    tddavis Moderator, Website User Posts: 5,059 Moderator

    @CooljaNitez Chances are that it is actually transparent but you have the viewer set to use a black background.  You can change this in the Options at the bottom right of the viewer window by selecting Checkerboard background, or you can quickly see that it is by dropping another image underneath the one in a composite shot.  You will be able to see the transparency that way.  Hope this is what you are seeing and helps you out.  You can always add a demult key effect to images with black backgrounds to make them transparent but it steals from the parts you want to keep a little as well.

  • Bry1234455
    Bry1234455 Website User Posts: 1

    Hey everyone, I noticed that if you just right click the picture and click 'blend' then click 'add' it removes the black background as long as the picture did actually have a transparent background prior to importing it.

  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,252 Staff

    @Bry1234455 that is true, but changing the blend mode will also make any colors in your image partially transparent, which is often undesirable.

  • BernhardWolf
    BernhardWolf Website User Posts: 1

    I had the same problem, I imported into Graphic's program then exported it again. And it worked.

  • lunaman
    lunaman Website User Posts: 1 Just Starting Out

    you can use this web photo editor.

    https://pixlr.com/x/

    just upload the image and download again.

This discussion has been closed.