Render Problem - Glitching Motion in Picture

AmorsonAmorson Website User Posts: 50

Hello. I use HitFilm 2 Ultimate and I'm working on this school project. My problem is that when I edit, it somehow looks like crap. I get these blurry lines whenever there is motion. However, they disappear when I set it to "Render: Half" instead of Anti Aliased or Full. Yet when I render my project the problem occurs yet again? It just doesn't look good to have these glitched lines whenever there is motion in the picture. I am filming with a SONY HDR-CX900. What should I do? I have a deadline soon :/   

Comments

  • PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast

    Turn off motion blur. It's in two or three places, one in the viewer, which is a little 'comet' icon in one of the corners (HF2U probably different to HF3 or 4)

    That's just for playback though, so also check the project and layer properties has it turned off.

    Warning: might look worse with it off, as things looking too sharp when moving looks false, which is why it's there,

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,228 Ambassador

    I'm wondering if the footage is in 1080i... If so, Hitfilm 2 doesn't interlace, so transcoding would be required. 

  • AmorsonAmorson Website User Posts: 50

    It's [HD]AVCHD filmed with a 50i framrate. 

  • AmorsonAmorson Website User Posts: 50
    edited April 2016

    Palacono I can't seem to find anything looking like a 'comet' near the viewer in HitFilm 2?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,228 Ambassador

    Amorson. 50i is your problem here. Hitfilm does not support interlaced footage, and Hitfilm 2 has no way to deinterlace (Hitfilm 3 Express does). You'll need to transcode your footage to a progressive format. Mpeg Streamclip can do this, Handbrake can do this and Hitfilm 3 Express can do this. Note with HF3E you have to re-render the footage. You can't open a 3E project in 2U.

    You should set your camera to a framerate ending in "p."

    For information on the difference between interlaced (50i) vs progressive (24p) read this: 

    http://www.isfforum.com/FAQs/view/All-About-HDTV/What-s-the-Difference-between-Interlaced-and-Progressive-Video/33.html

  • Aladdin4dAladdin4d Moderator Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,509 Enthusiast

    Yep you're going to have to transcode and deinterlace first. I'm going to suggest Handbrake because it's free, another forum member NormanPCN has developed settings that make for easier editing in HitFilm and it has a good deinterlacing filter. 

    Watch this video starting @ 8:03 for tips on what settings to use with Handbrake. Beyond that since you need to deinterlace too you'll want to go to the Filters tab, select Deinterlace and set it to Slow or Slower.

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,228 Ambassador

    Hitfilm 2 doesn't have a button for motion blur in the layer stack. There's a checkbox in layer properties, but motion blur isn't the problem, it's really interlacing. 

    Assuming you read the article above: since "Fields" are alternating lines of pixels, shifting to half-res you're only using odd or even numbered fields to display the image which hides the interlace. 

  • PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast

    Yeah, I guessed and was wrong, then wrong about what to look for. Let's see...the sky is green. Three for three! :)

  • AmorsonAmorson Website User Posts: 50

    Aladdin4d. Do I then have to Handbrake every single raw file in the project and re edit? 

  • Aladdin4dAladdin4d Moderator Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,509 Enthusiast

    You won't have to re-edit but you will need to re-link your media to the new versions. What's the file extension for your existing files?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,228 Ambassador

    Yes, but Handbrake can batch process, so you can at least set all your clips up to render at once.

    What's the file extension on your source clips? If it's "mp4" then you can kind of trick Hitfilm by saving all your clips from Handbrake to a different folder but with the exact same name. Then move the original clips somewhere else. Moving the original files means when you reopen the project Hitfilm will say tge media is missing... So tell Hitfilm to use the new fikes. Actually that probably works even if the file extensions are different! 

    This tutorial covers the basics of Handbrake. 

    And this one has some custom settings to maximize Mp4 performance in Hitfilm. 

  • AmorsonAmorson Website User Posts: 50

    Aladdin4d:
    .MTS is that what you mean?  :) 

  • Aladdin4dAladdin4d Moderator Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,509 Enthusiast

    Yes it is! So when you run your clips through Handbrake make sure they come out using the same name. The only thing that should be different is the extension which will be mp4. Then do what Triem23 says, move your original clips to somewhere else and open your project. When HitFilm says the media is missing, point it to your new mp4 files. You might have to this for each file but there's a good chance you won't.

Sign In or Register to comment.