How do I import an Image sequence?

PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast
edited February 2016 in Post-production techniques

I'm obviously being dumb, but the manual is no help. It just says I can do it...

All I want to do is import a load of .TGA files, which have been previously exported by something else. I can import them as Media, but can't see how to get them in as a sequence.

I select the Folder they're in: Error. Invalid Media, the Media could not be imported. WTH?

I rename the folder to be the same name as the first file in it 'Image' for 'Image0001.tga' and so on. Still Error.

I open the folder: nothing to select.

What am I doing wrong and why isn't this easier? :)

Comments

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,254 Ambassador

    Open the folder, then, after you see "nothing" just Ok. 

    I think the logic is, Hitfilm's expecting sequencial files, but you're selecting the FOLDER not the files in it. 

  • PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast
    edited February 2016

    @Triem23, Nope that doesn't work. All I get after I open the folder is a blank folder and the Select Folder button. There is no OK.

    If I start typing up pops up a list of files that match the name, but nothing I've tried actually selects anything to load.  Tried wildcards: nothing.

    This is ridiculous.

  • AxelWilkinsonAxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,241 Staff
    edited February 2016

    .TGA files aren't supported by HitFilm. Convert them to one of the supported image formats and you should have better success: http://hitfilm.com/reference-manuals/hitfilm-4-pro#supported_formats.htm

    I do seem to recall some work being done a while back to support that format, I'm not sure if it just wasn't updated in the manual or if they are not fully supported yet. Either way, converting the files should tell the tale. Also, make sure there are no files in the folder that are not part of the image sequence.

  • PalaconoPalacono Website User, HitFilm Beta Tester Posts: 3,442 Enthusiast
    edited February 2016

    @AxelWilkinson well, your answer was half right. ;)

    Hitfilm actually loads in .TGA files with no problem, but there was also some other information in that folder which was evidently the issue.

    Having a filter option (as when loading media) to select *.TGA files to load would fix that problem. However, moving all the .TGA files to another folder on their own solved the problem and they're now loaded. Yay!

    Thanks all. (Add a filter to the loader, or improve the error message...) ;)

  • Aladdin4dAladdin4d Moderator Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,509 Enthusiast

    Sorry I was busy earlier :) but yeah the images of an image sequence must be the only thing in the folder. Anything else besides images and the import will fail. 

    I agree importing an image sequence should be reworked even more so than just adding a filter. You should also be able to select a range within a sequence. With Sony Vegas you can select the very first image and tick Open Sequence to get the entire sequence or pick what image you want to be first, tick Open Sequence and import everything from that image on as a sequence or pick the what image you want first, tick Open Sequence and manually enter what you want the last image to be to import just that range.

Sign In or Register to comment.