Hitfilm Runs Super Slow and Often Goes Unresponsive

TrevorSchnedlerTrevorSchnedler Website User Posts: 2

Hello, I've been having this problem since I got Hitfilm almost 2 years ago, but still haven't found a fix or any help on it. It runs extremely slow playing video, scrubbing through, really anything. I have a video of it that should help out. My current pc is no slouch and I've watched the task manager during editing to see if anything is maxed out, or bottlenecking but everything always looks normal (cpu, ram, hdd, gpu). My friend with an identical cpu has this exact same problem and neither of us have figured it out, but we believe it is most likely the cpu not being well supported for HF. I want to make sure there I've covered all my bases before I make the decision to switch to Intel to fix it, or just switch to premiere since it's supported (assuming it's my cpu) 

This is my build:

-MSI 970 Gaming Mobo

-AMD FX8320 Black CPU

-8Gb G Skill DDR3 1600

-WD Black Hard drive

-GTX 970

Here's a video of it -Sorry I realized afterward that the cursor wasn't displayed but I think it still shows the problem. This gets much much worse  as edits progress, and more footage racks up, sometimes it gets to the point where if you try to edit at all, it just goes unresponsive.

Comments

  • TrevorSchnedlerTrevorSchnedler Website User Posts: 2

    Here's another video with the cursor, which helps out a little but still doesn't do it justice because like I mentioned above, it gets REALLY bad when I'm working on a full project. Like, the play head won't move or the video won't start playing for like 5, even 10 seconds sometimes.

  • karmakarma Website User Posts: 165 Enthusiast
    edited February 2016

    Upgrade to 4 Pro and use proxies on everything.  Then scrubbing and edits will be a breeze.  Takes a while to render, but a pleasure once it does.

    Fact is, no matter how powerful the computer and video card, eventually compositing will choke even the strongest of computers as you add layers that require lots of computations.  Once it gets pretty stacked, you could wait for minutes even before you see something on screen.

    Make sure to turn OFF motion blur on ALL layers/comps and reduce the quality of everything to DRAFT until the final render is needed.  If using Boris, make sure to ramp the quality level all the way down.

    It's all about lowering the overall quality of the render while comping/editing so your cpu/gpu/memory does not have to do so much at once.  Remember, it also has to run windows/mac OS (whatever machine you have) and all the crud running at that time.

    I would streamline your computer as much as possible.  Make sure NO OTHER SOFTWARE is running at the same time.  Make sure your startup is not filled with tons and tons of crap programs running for no real reason.  Make sure you have no viruses/malware/trojans/worms, etc. Alter the quality settings of Windows display to PERFORMANCE mode, which turns off Windows Aero - which can suck up memory and gpu like nothing you ever saw - and for almost no good reason (who cares about real time drop shadows and transparency on windows????).

    It's all about making your machine lean, mean and running as smoothly as possible BEFORE running any high quality, gpu/cpu intensive program like Hitfilm and any other compositor or 3D animation software.

    Mike

  • AxelWilkinsonAxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,242 Staff

    What codec are your .mov files encoded with? My guess is that they haven't yet been converted to a codec designed for editing. If not, then converting them to DNxHD or something similar will significantly improve performance. 

This discussion has been closed.