Hitfilm 4 Pro and Hitfilm 3 Express Crashing

Hi. I've downloaded the free version of Hitfilm 3 and also the trial version of Hitfilm 4 Pro (originally with the intent of buying it) However whenever I try to import any form of media, a window comes up saying, "HitFilm 4 Pro has stopped working: A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." This identical program happens with Hitfilm 3.

I have an Alienware With an IntelCore i7 CPU, 16GB of RAM, a 64-bit processor and plenty of space. I've also installed the latest version of Quicktime. 

Does anyone know what's wrong? Because I'd really like to get Hitfilm 4.

Comments

  • Yeremyah
    Yeremyah Posts: 995 Enthusiast
  • Yeremyah
    Yeremyah Posts: 995 Enthusiast
    edited January 2016

    Have you tried creating a new account, and installed it into a fresh account with no other apps running?

    Also, what is your 'Preferred graphics processor' setting at? You got a NVIDIA processor?

    Those gaming machines seem to cause some issues?

     

  • SimonKJones
    SimonKJones Posts: 4,370 Enthusiast

    What graphics card? It's most likely due to the graphics card being below spec or using an old driver. If you're on a laptop, it might be defaulting to using the lower powered GPU.

  • VictorVideo
    VictorVideo Posts: 4 Enthusiast

    I am using Hitfilm 4 on 64 bit Toshiba laptop with an Intel (R) HD Graphics 3000 and it crashes when trying to create a project. Hitfilm 2 Pro works fine.  Hitfilm 3 Express works as well.  Any suggestions.  Simon noted that laptops might be defaulting to lower powered GPU.  Can this be prevented?

    Simon 

     

  • Triem23
    Triem23 Posts: 20,288 Power User
    edited January 2016

    @VictorVideo Hitfilm 4 pro requires an Intel 4000 or higher. Technically, so does Hitfilm 3 Express, so I am surprised that runs on your system. 

    What @SimonKJones refers to are laptops with Dual Intel Nvidia/AMD cards, where the system software might need to be told to use the Nvidia/AMD card in Hitfilm. If you only have the Intel 3000, this won't apply to you, but, unfortunately the 3000 is below minimum specifications for Hitfilm 4. 

  • WhiteCranePhoto
    WhiteCranePhoto Posts: 923 Enthusiast

    If you have a discrete GPU you may be able to set a preference for which one HitFilm launches on. With an nVidia card it's in the 3D settings control panel, in application specific settings. I'm not sure about the AMD equivalent.

    The HD 3000 GPU might be the culprit, but it might just be the drivers. Either way, if you have a discrete GPU, you're going to have a better experience if you switch HitFilm to that one. 

  • I have the same problem with Hitfilm 4 pro, no problems with HitFilm 3 Expres, when I add elements, it goes down (Crashing) 

    8 GB RAM, Intel i7-3612QM @ 2.10GHz, Intel HD Graphics 4000 + NVIDIA GeForce GT 630M, Windows 7 Home

  • Yeremyah
    Yeremyah Posts: 995 Enthusiast

    Steffen, what is your NVIDIA 'Preferred graphics processor' setting at?

This discussion has been closed.