can't see 3d model

sbradysbrady Website User Posts: 28

I can hardly see the 3D model in the comp.

I can't switch to different views, top, perspective etc

I want to buy this app but need this working before I buy, no buyers remorse here.


  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,262 Ambassador
    edited January 2016

     Top left of the viewer panel, where it says "Active Camera" is the drop-down for other views. Top center of the viewer panel, where it says "Views: 1"is the drop-down fir switching to multi-pane viewing. Bottom left of Viewer Panel, the Blue icon that looks like a square with a cross in it is the toggle to turn off the perspective grid in the main viewer if you want. 

    Otherwise, where is the model from? Have you checked it's diffuse and specular colors when importing to make certain those colors aren't set to black or a dark grey? I ask because my primary use of the software is 3D animation and particles, and I will say from experience that Hitfilm does a very good job at it--not on the level of a dedicated 3D program, but very good, nonetheless. 

    Check out the Hitfilm YouTube channel. There's a full playlist of tutorials for 3D models. Many of them were created in earlier versions of Hitfilm, but everything is the same in Hitfilm 4 as in earlier versions. The only thing not currently covered by a dedicated Hitfilm 4 Pro tutorial is the Cook-Torrance shader controls, although those are briefly covered in the what's new in Hitfilm 4 video. 

  • sbradysbrady Website User Posts: 28

     lightbulb moment.....I think its NOT showing up because the body is a UV. Can Hitfilm handle UV textures. I'll make another version with NO uv, just a color.

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,262 Ambassador

    Yes, however, if the textures are not in the same folder as the model, you'll have to manually relink on import. 

    Hitfilm is primarily a compositing/VFX tool that happens to have editing and limited 3D capabilities. I, again, suggest you check the 3D models tutorials--at least for import--to familiarize yourself with the differences between Hitfilm and Lightwave import. Once you have watched just that one tutorial you'll be ready to poke around. 

    It should be noted that animation groups and base scale can't be changed once a model is imported, so you want to get those right the first time. Texture and material settings can be altered at any time. 

    Hold that thought. Let me find the two tutorials you should watch first. 

  • sbradysbrady Website User Posts: 28
  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,262 Ambassador

    Basic import

     Basic Materials--note you'll have settings to adjust both in the model import AND the model timeline layer. 

    Intro to 3D unified space in Hitfilm. More to show how you might want to set up an airplane scene 

    A community tutorial on setting up the Particle sim with 3D models--using Sopwith Camels I think. 

    Note these are HF 2 and 3 tutorials. You'll have a few extra options to play with in 4. 

    Note if you're an experienced Lightwave artist, Hitfilm's rigging won't support IK. Just animation groups. For objects and vehicles you can  rig each group to it's own point, or do direct transforms on each group--great for cars, planes, coptors, speceships, etc, but if you want full character animation you'll have to create and export Alembuc data in Hitfilm. 

    This should get you started on your evaluation. If you have more questions, we're a friendly forum. 

  • MessenMessen Website User Posts: 86 Enthusiast

    This kind of problem was happened to me too. I had an asteroid model and it was unnaturally dark even if I placed next to a very bright light source.

    First I tried to add a neutral (grey) color instead of the textures. There were no difference. After that I checked the normals of the faces and they were reversed, turned inwards. I don't know why. It looked like ok in Blender. Maybe it was an export issue. I don't know if it's happened to you too, but it was a solution of my problem kinda like this.

Sign In or Register to comment.