HF2 Ult: Particle Deflection using 3D Model?

Hey all! New to the software and just learning the loops! I come from an extensive background with After Effects and Premiere, and have used Mocha tracking before. Never before though, have I seen such a complete set of tools in one single program! I'm very excited to bring this into my workflow, as I can only see the potential growing over the next few years!
First post, and first question: I am setting up a simple 3D composite over some stock footage I shot a few days ago. Simple scene, using the Helicopter from the import tutorial on a scene I MoTracked. The camera is walking down a road, and the helo is sitting touched down, with the rotor blades spinning. It's lit & graded and looks great, but it's missing some dust kickoff from the ground. 
I've got my dust particle (based off missile smoke) all set up, but none of my planes are working as deflectors. Also, is there a way of setting up an imported model as a deflector, or would I have to build planes around the body of the Helicopter?
Attached two screen shots, one without smoke and one with the smoke (just at default settings other than ground plane deflector).
What would you seasoned pros recommend? I want to give the effect of the dust being kicked up from the rotor wash.

Comments

  • NullUnitNullUnit Website User Posts: 791 Just Starting Out
    edited May 2013
    Planes only deflect particles on one side. So, you may need to flip the deflector by 180 degrees. 
    Models cant be used as deflectors (thats on the "wish list" for updates). 
    In terms of the dust being kicked up by the rotors, I would make a smoke/dust effect for in front of the model and behind (layered on top and below in the track pane), since (for now) particles dont exist in the same 3d space as models (also on the wish list). I'm not sure if the preset you chose lets you go into the emitter controls (some do) but, you would want to add "forces" to your particles so that they are pulled up when emitted and then pushed/pulled back down again. I think that would make them swirl in a way that a rotor would make them.   
  • OrangePekoeOrangePekoe Website User Posts: 478
    Welcome to the forums!
    You're correct regarding the need to build yourself some deflectors "around" a 3D object if you want to give the impression that the particles are "interacting" with the imported model. Really hoping one day we can use 3D models as deflectors.
    As for the deflectors, are the particles not interacting at all with the planes? Try flipping the planes in question 180 degrees so that what is currently the underside is now the surface. I can't remember off hand if there was an option to make both faces enabled for deflection (replying from phone so can't check atm).
    Is the deflector plane set at infinity?
    Hope that helps for now!
  • EmmaEmma Staff Administrator, HitFilm Beta Tester Posts: 79 Staff
    Hey, just wanted to clarify that in HitFilm 2, particles collide with both sides of a plane by default. You don't need to flip the deflector like you did in HitFilm 1 to get particles to collide with the 'front' face. You can change this behavior using the Deflector > General > Front Face / Back Face check boxes.
    One thing to note is that particles collide with deflectors at their center point; so if you're using a large texture, it might look like your particles aren't colliding when actually they are?
  • HireTheStacheHireTheStache Website User Posts: 18
    Awesome everyone, thanks for clarifying! I got a pretty decent looking dust going, built a rudimentary box around the helo, and now I just have to render it out. @Emma, I did notice what you mentioned with the large textures such as cloud/dust. I noticed when turning preview on/off, that the particle was in fact being deflected, and it was only the texture that was remaining visible. Shame theres not a way yet to deflect/kill/mask textures on any given axis.
  • NullUnitNullUnit Website User Posts: 791 Just Starting Out
    Awesome everyone, thanks for clarifying! I got a pretty decent looking dust going, built a rudimentary box around the helo, and now I just have to render it out. @Emma, I did notice what you mentioned with the large textures such as cloud/dust. I noticed when turning preview on/off, that the particle was in fact being deflected, and it was only the texture that was remaining visible. Shame theres not a way yet to deflect/kill/mask textures on any given axis.


    You can use the "lifetime panel" to set up when the textures will fade out. 

  • HireTheStacheHireTheStache Website User Posts: 18
    Wasnt able to render using the particles due to a software issue, but here's what I came up with anyways!
    http://hitfilm.com/movies/51a5916737c0f
  • OrangePekoeOrangePekoe Website User Posts: 478
    Wasnt able to render using the particles due to a software issue, but here's what I came up with anyways!
    http://hitfilm.com/movies/51a5916737c0f

    That looks awesome! 
    Have you tried rendering out just the particle system you've created?  Does that work on it's own? 
     

  • SimonKJonesSimonKJones Moderator Website User, HitFilm Beta Tester Posts: 4,450 Enthusiast
    That's a very nice composite indeed!
  • HireTheStacheHireTheStache Website User Posts: 18
    That looks awesome! 
    Have you tried rendering out just the particle system you've created?  Does that work on it's own? 
     


    Just tried, no success :( Such a shame that I am limited to the weakest link on my computer. 

  • OrangePekoeOrangePekoe Website User Posts: 478

    Just tried, no success :( Such a shame that I am limited to the weakest link on my computer. 

     
    Does your laptop have dual graphics cards?  HD3000/4000 for normal tasks and the 560m for more intensive tasks?  If so, can you switch to just the 560m rather than have windows choose?
    Do have you the latest set of nvidia drivers? 
     

  • HireTheStacheHireTheStache Website User Posts: 18
     
    Does your laptop have dual graphics cards?  HD3000/4000 for normal tasks and the 560m for more intensive tasks?  If so, can you switch to just the 560m rather than have windows choose?
    Do have you the latest set of nvidia drivers? 
     

    How would I go about managing the switching? 
    And yes, I have the latest drivers. I tried everything from rolling back to older working drivers, to the last driver I had, to the current...nothing :( 

  • OrangePekoeOrangePekoe Website User Posts: 478
    How would I go about managing the switching? 
    And yes, I have the latest drivers. I tried everything from rolling back to older working drivers, to the last driver I had, to the current...nothing :( 

    Open up your Nvidia Control Panel - Look for the 3D settings tab - choose manage 3D settings - Select your discrete graphics card as the default for HitFilm and / or just set the Global Settings to use only the 560m for now to test things out. 
     

  • HireTheStacheHireTheStache Website User Posts: 18
    Just added HitFilm to Program Settings under Nvidia CP, and tried a mix of settings all to no positive result :( 
  • HireTheStacheHireTheStache Website User Posts: 18
    Exciting update, I got everything up and running (will explain how), heres the final render:
    http://hitfilm.com/movies/51a6ae9120f84
  • HireTheStacheHireTheStache Website User Posts: 18
    Just an update for others who hit this issue. I was not running into any actual GPU errors--my temperatures were all nominal, and the system was stable. But with full rendering at about .8 FPS, windows THOUGHT my GPU was unresponsive, and restarted the display driver. 
    My fix was to disable Windows Reporting specifically for the GPU, by adding the following registry entry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers
    Create a new REG_DWORD entry:
    TdrLevel 
    Value Data: 0
    Hexadecimal
    Restart
    Et'Voila!
  • OrangePekoeOrangePekoe Website User Posts: 478
    Just an update for others who hit this issue. I was not running into any actual GPU errors--my temperatures were all nominal, and the system was stable. But with full rendering at about .8 FPS, windows THOUGHT my GPU was unresponsive, and restarted the display driver. 
    My fix was to disable Windows Reporting specifically for the GPU, by adding the following registry entry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers
    Create a new REG_DWORD entry:
    TdrLevel 
    Value Data: 0
    Hexadecimal
    Restart
    Et'Voila!

    Really glad you managed to figure out a solution to the issue!
    Just curious, how do you go about adding a registry entry?

  • HireTheStacheHireTheStache Website User Posts: 18
    Start>Type regedit :)
Sign In or Register to comment.