Audio Not Deleting in Composite Shot

I imported a video clip into the editor and unlinked the audio and then I deleted it.
I then right clicked on the clip to make a composite shot but the audio was still there even though I had deleted it.
I had to export the clip from the editor without the audio and then re-import it to make a composite shot without audio.
Why didn't the audio stay deleted in the composite shot?
I tried taking the composite shot properties from the current timeline and moving with layer but neither worked.
The audio wouldn't go away in the composite shot but it deleted in the editor.

Comments

  • Robin
    Robin Posts: 1,659 Enthusiast
    Uh, now that's diving into the software mechanisms... I don't know how exactly it works, but I'd guess that the different timelines have different approaches to working with the video and audio parts of a media file.
    If you just want to now how to work around that problem: Just mute the track in the composite shot by toggling the mute checkbox in the layer properties, and the comp shot shouldn't have audio anymore ;)
    It will add the audio track in the editor again, but you can again unlink and delete that.
    If you're interested in what I think are the underlying software mechanics causing that behavior, read on :P
    On the editor timeline, the video and audio get split, so if you import a media file, it's audio and video parts get separate tracks on the timline, which you can (after unlinking) individually edit, move and delete. So the video tracks can't contain any sort of audio, they just pull the video from the media file, and so do the audio files with the audio.
    On the composite timeline though, one layer can contain both video and audio - in fact, if you import a video in there, it also imports its audio, and you can't separate the two. You also can't import the audio alone, I think. And so, when you make the video track which you deleted the audio from into a composite shot, it basically takes the media the video track uses and puts it into a composite shot - as you can't separate video and audio in a composite shot timeline, the audio is back there because it's again being pulled from the media file.
    Also, the software re-adds the audio track for the new comp shot, because you could add additional audio inside the comp shot, even if the original video is muted - and I currently know of no way of re-adding an audio track of a layer back on to the timeline without re-adding the whole layer, so it does this just in case you'd need it.
    Again I'm not one of the devs, but this seems logical to me.
  • HitFilmer289932
    HitFilmer289932 Posts: 83 Enthusiast
    That explains it even though you'd think that once you've deleted the audio it would stay deleted but lowering it to a mute solves the problem anyway.
    Thanks
  • AxelWilkinson
    AxelWilkinson Posts: 5,255 Staff
    In addition to lowering the actual audio level until its muted, there is a Mute button in the Layer Properties for any layer in a comp which contains audio. Which makes it really easy to tick the audio on or off as needed.
  • HitFilmer289932
    HitFilmer289932 Posts: 83 Enthusiast
    I now see the mute in the layer properties in the control panel.
    Thanks
  • I've got the audio muted in the composite shot video and I've added a separate audio clip from my zoom h4n.  I'm trying to sync my audio from the zoom h4n with the video using the Audio Wave Atomic Particle.  When ever I select the audio clip under effects>atomic particle>audio interaction>audio layer the visual audio wave disappears.
    I have a video with audio and a separate audio file from the zoom.  The real question is how do I sync the video with the higher quality zoom audio file?
    I am a novice and I watched:  http://community.hitfilm.com/index.php?/topic/4086-timeline-audio-visual-option/?hl=%2Bsync+%2Baudio+%2Bwith+%2Bvideo#entry33142
    There just isn't enough info for me to accomplish the task.  Even though I can visually see the atomic particle in the composite shot I'm not sure how to edit the audio track to match up with the video, even if I wanted to use the movie audio.
    Thanks,
    Eileen
  • duffman
    duffman Posts: 234 Enthusiast
    Eileen,
    Have you tried, in the editor,
    importing your video with it's audio,
    unlink the  original audio and delete
    import your new audio file from the Zoom and place in the editor
    align the new audio track as need
    then export/render.
    This will give you the original video clip with the better audio married up in 1 clip.

    Duff